On Thu, Apr 24, 2025 at 1:34 AM Maxime Ripard mripard@kernel.org wrote:
On Tue, Apr 22, 2025 at 12:19:39PM -0700, Jared Kangas wrote:
@@ -22,6 +22,7 @@ #include <linux/slab.h> #include <linux/vmalloc.h>
+#define DEFAULT_CMA_NAME "default_cma"
I appreciate this is kind of bikeshed-color territory, but I think "cma" would be a better option here. There's nothing "default" about it.
I disagree. It very much is "default" as it's returning the dma_contiguous_default_area.
There can be multiple CMA areas, and out of tree, vendors do reserve separate areas for specific purposes, exposing multiple CMA dmabuf heaps. There have been patches to expose multiple CMA heaps, but with no upstream drivers using those purpose specific regions, we haven't taken them yet. I do hope as the drivers that utilize these purpose focused heaps go upstream, we can add that logic, so I think being specific that this is default CMA is a good idea.
thanks -john