Here is the fourth version for converting parport device(ppdev) to y2038 safe. The first three could found at [1], [2], [3].
An y2038 safe application/kernel use 64bit time_t(aka time64_t) instead of 32bit time_t. There are the 5 cases need to support:
summary |u:arch |u:tv_sec |k:arch |k:tv_sec -------------------|-------|---------|-------|-------- 32_y2038_unsafe |32 |32 |32 |32 32_y2038_safe |32 |64 |32 |64 compat_y2038_unsafe|32 |32 |64 |64 compat_y2038_safe |32 |64 |64 |64 64_y2038_safe |64 |64 |64 |64
notes: 1. xxx_y2038_safe/unsafe. 32 means app running on the 32bit kernel. Compat means 32bit app running on 64bit kernel. 64 means 64bit app running on 64bit kernel. 2. 1.3.5 are the original one, we need keep the compatability. 2,4 is new one we need to support.
There are different ways to do this. Convert to 64bit time and/or define COMPAT_USE_64BIT_TIME 0 or 1 to indicate y2038 safe or unsafe.
But it is not mean that we need to convert all the time relative struct to 64bit. Because some time relative struct(e.g. timeval in ppdev.c) is mainly the offset of the real time.
The main issue in ppdev.c is PPSETTIME/PPGETTIME which transfer timeval between user space and kernel. My approach here is handle them as different ioctl command.
Build successful on arm64 and arm.
Changes since V3: 1. create pp_set_timeout, pp_get_timeout to reduce the duplicated code in my patch according to the suggestion of arnd. I use div_u64_rem instead of jiffies_to_timespec64 because it could save a divide operaion.
[1] https://lists.linaro.org/pipermail/y2038/2015-June/000522.html [2] https://lists.linaro.org/pipermail/y2038/2015-June/000567.html [3] https://lists.linaro.org/pipermail/y2038/2015-November/001093.html
Bamvor Jian Zhang (2): ppdev: convert to y2038 safe ppdev: add support for compat ioctl
drivers/char/ppdev.c | 91 ++++++++++++++++++++++++++++++++++++++++------------ 1 file changed, 71 insertions(+), 20 deletions(-)
The y2038 issue for ppdev is changes of timeval in the ioctl (PPSETTIME and PPGETTIME). The size of struct timeval changes from 8bytes to 16bytes due to the changes of time_t. It lead to the changes of the command of ioctl, e.g. for PPGETTIME, We have:
on 32-bit (old): 0x80087095 on 32-bit (new): 0x80107095 on 64-bit : 0x80107095
This patch define these two ioctl commands to support the y2038 safe and y2038 unsafe application at the same time. And, introduce pp_set_timeout and pp_get_timeout to remove some duplicated code.
Signed-off-by: Bamvor Jian Zhang bamvor.zhangjian@linaro.org --- drivers/char/ppdev.c | 80 +++++++++++++++++++++++++++++++++++++++------------- 1 file changed, 60 insertions(+), 20 deletions(-)
diff --git a/drivers/char/ppdev.c b/drivers/char/ppdev.c index ae0b42b..829ebab 100644 --- a/drivers/char/ppdev.c +++ b/drivers/char/ppdev.c @@ -98,6 +98,13 @@ struct pp_struct { #define ROUND_UP(x,y) (((x)+(y)-1)/(y))
static DEFINE_MUTEX(pp_do_mutex); + +/* define fixed sized ioctl cmd for y2038 migration */ +#define PPGETTIME_unsafe _IOR(PP_IOCTL, 0x95, s32[2]) +#define PPSETTIME_unsafe _IOW(PP_IOCTL, 0x96, s32[2]) +#define PPGETTIME_safe _IOR(PP_IOCTL, 0x95, s64[2]) +#define PPSETTIME_safe _IOW(PP_IOCTL, 0x96, s64[2]) + static inline void pp_enable_irq (struct pp_struct *pp) { struct parport *port = pp->pdev->port; @@ -322,6 +329,32 @@ static enum ieee1284_phase init_phase (int mode) return IEEE1284_PH_FWD_IDLE; }
+static int pp_set_timeout(struct pardevice *pdev, __kernel_time_t tv_sec, + __kernel_suseconds_t tv_usec) +{ + long to_jiffies; + + if ((tv_sec < 0) || (tv_usec < 0)) + return -EINVAL; + + to_jiffies = usecs_to_jiffies(tv_usec); + to_jiffies += tv_sec * (long)HZ; + if (to_jiffies <= 0) + return -EINVAL; + + pdev->timeout = to_jiffies; + return 0; +} + +static void pp_get_timeout(struct pardevice *pdev, s64 *tv_sec, s64 *tv_usec) +{ + u32 rem; + + *tv_sec = div_u64_rem((u64)(pdev->timeout) * TICK_USEC, + USEC_PER_SEC, &rem); + *tv_usec = rem; +} + static int pp_do_ioctl(struct file *file, unsigned int cmd, unsigned long arg) { unsigned int minor = iminor(file_inode(file)); @@ -495,9 +528,9 @@ static int pp_do_ioctl(struct file *file, unsigned int cmd, unsigned long arg) unsigned char reg; unsigned char mask; int mode; + s32 time32[2]; + s64 time64[2]; int ret; - struct timeval par_timeout; - long to_jiffies;
case PPRSTATUS: reg = parport_read_status (port); @@ -592,29 +625,36 @@ static int pp_do_ioctl(struct file *file, unsigned int cmd, unsigned long arg) atomic_sub (ret, &pp->irqc); return 0;
- case PPSETTIME: - if (copy_from_user (&par_timeout, argp, sizeof(struct timeval))) { + case PPSETTIME_unsafe: + if (copy_from_user(time32, argp, sizeof(time32))) return -EFAULT; - } - /* Convert to jiffies, place in pp->pdev->timeout */ - if ((par_timeout.tv_sec < 0) || (par_timeout.tv_usec < 0)) { - return -EINVAL; - } - to_jiffies = ROUND_UP(par_timeout.tv_usec, 1000000/HZ); - to_jiffies += par_timeout.tv_sec * (long)HZ; - if (to_jiffies <= 0) { + + return pp_set_timeout(pp->pdev, time32[0], time32[1]); + + case PPSETTIME_safe: + if (copy_from_user(time64, argp, sizeof(time64))) + return -EFAULT; + + return pp_set_timeout(pp->pdev, time64[0], time64[1]); + + case PPGETTIME_unsafe: + pp_get_timeout(pp->pdev, (s64*)&time32[0], (s64*)&time32[1]); + if ((time32[0] < 0) || (time32[1] < 0)) return -EINVAL; - } - pp->pdev->timeout = to_jiffies; + + if (copy_to_user(time32, argp, sizeof(time32))) + return -EFAULT; + return 0;
- case PPGETTIME: - to_jiffies = pp->pdev->timeout; - memset(&par_timeout, 0, sizeof(par_timeout)); - par_timeout.tv_sec = to_jiffies / HZ; - par_timeout.tv_usec = (to_jiffies % (long)HZ) * (1000000/HZ); - if (copy_to_user (argp, &par_timeout, sizeof(struct timeval))) + case PPGETTIME_safe: + pp_get_timeout(pp->pdev, &time64[0], &time64[1]); + if ((time64[0] < 0) || (time64[1] < 0)) + return -EINVAL; + + if (copy_to_user(time64, argp, sizeof(time64))) return -EFAULT; + return 0;
default:
On Monday 16 November 2015 07:31:12 Bamvor Jian Zhang wrote:
@@ -322,6 +329,32 @@ static enum ieee1284_phase init_phase (int mode) return IEEE1284_PH_FWD_IDLE; } +static int pp_set_timeout(struct pardevice *pdev, __kernel_time_t tv_sec,
__kernel_suseconds_t tv_usec)
+{
- long to_jiffies;
- if ((tv_sec < 0) || (tv_usec < 0))
return -EINVAL;
- to_jiffies = usecs_to_jiffies(tv_usec);
- to_jiffies += tv_sec * (long)HZ;
- if (to_jiffies <= 0)
return -EINVAL;
- pdev->timeout = to_jiffies;
- return 0;
+}
The code looks good, but now your prototype has a '__kernel_time_t', and we are in the process of removing all instances of that from the kernel so we can eventually remove the definition and make sure that no drivers start using it.
Better just use 'long' for tv_sec and tv_usec.
+static void pp_get_timeout(struct pardevice *pdev, s64 *tv_sec, s64 *tv_usec) +{
- u32 rem;
- *tv_sec = div_u64_rem((u64)(pdev->timeout) * TICK_USEC,
USEC_PER_SEC, &rem);
- *tv_usec = rem;
+}
- case PPGETTIME_unsafe:
pp_get_timeout(pp->pdev, (s64*)&time32[0], (s64*)&time32[1]);
This does not do the right thing: You pass a pointer to a 32-bit variable into a function that takes a pointer to a 64-bit variable, so you get a stack overflow writing to the second half!
Arnd
The arg of ioctl in ppdev is the pointer of integer except the timeval in PPSETTIME, PPGETTIME. Different size of timeval is already supported by the previous patches. So, it is safe to add compat support.
Signed-off-by: Bamvor Jian Zhang bamvor.zhangjian@linaro.org --- drivers/char/ppdev.c | 11 +++++++++++ 1 file changed, 11 insertions(+)
diff --git a/drivers/char/ppdev.c b/drivers/char/ppdev.c index 829ebab..8c90cc5 100644 --- a/drivers/char/ppdev.c +++ b/drivers/char/ppdev.c @@ -675,6 +675,14 @@ static long pp_ioctl(struct file *file, unsigned int cmd, unsigned long arg) return ret; }
+#ifdef CONFIG_COMPAT +static long pp_compat_ioctl(struct file *file, unsigned int cmd, + unsigned long arg) +{ + return pp_ioctl(file, cmd, (unsigned long)compat_ptr(arg)); +} +#endif + static int pp_open (struct inode * inode, struct file * file) { unsigned int minor = iminor(inode); @@ -784,6 +792,9 @@ static const struct file_operations pp_fops = { .write = pp_write, .poll = pp_poll, .unlocked_ioctl = pp_ioctl, +#ifdef CONFIG_COMPAT + .compat_ioctl = pp_compat_ioctl, +#endif .open = pp_open, .release = pp_release, };
On Monday 16 November 2015 07:31:13 Bamvor Jian Zhang wrote:
The arg of ioctl in ppdev is the pointer of integer except the timeval in PPSETTIME, PPGETTIME. Different size of timeval is already supported by the previous patches. So, it is safe to add compat support.
Signed-off-by: Bamvor Jian Zhang bamvor.zhangjian@linaro.org
I've replied with
Reviewed-by: Arnd Bergmann arnd@arndb.de
to the previous submission of this patch, so you should add that line below your Signed-off-by when sending the patch again, otherwise that tag gets lost when the new version is applied.
Arnd