This is an automated email from the git hooks/post-receive script.
unknown user pushed a change to branch master in repository llvm.
from f3c6d22768b [DAGCombiner] fix variable names in isAlias(); NFCI new 3e9c4ea1fe1 [SVE] Fix mismatched sign comparison warning in unit test f [...] new 54f0462d2b7 [APInt] Rename getSignBit to getSignMask new 2a7d654e648 Resubmit "[BitVector] Add operator<<= and operator>>=."
The 3 revisions listed above as "new" are entirely new to this repository and will be described in separate emails. The revisions listed as "adds" were already present in the repository and have only been added to this reference.
Summary of changes: include/llvm/ADT/APInt.h | 12 +- include/llvm/ADT/BitVector.h | 149 +++++++++++++++++++++ include/llvm/ADT/SmallBitVector.h | 16 +++ include/llvm/IR/PatternMatch.h | 10 +- lib/Analysis/InstructionSimplify.cpp | 8 +- lib/Analysis/ScalarEvolution.cpp | 8 +- lib/Analysis/ValueTracking.cpp | 6 +- lib/CodeGen/SelectionDAG/DAGCombiner.cpp | 22 +-- lib/CodeGen/SelectionDAG/LegalizeDAG.cpp | 4 +- lib/CodeGen/SelectionDAG/SelectionDAG.cpp | 24 ++-- lib/CodeGen/SelectionDAG/TargetLowering.cpp | 16 +-- lib/Target/X86/X86ISelLowering.cpp | 32 ++--- lib/Transforms/InstCombine/InstCombineAddSub.cpp | 12 +- lib/Transforms/InstCombine/InstCombineAndOrXor.cpp | 4 +- lib/Transforms/InstCombine/InstCombineCompares.cpp | 20 +-- .../InstCombine/InstCombineMulDivRem.cpp | 4 +- lib/Transforms/InstCombine/InstCombineSelect.cpp | 2 +- lib/Transforms/InstCombine/InstCombineShifts.cpp | 2 +- .../InstCombine/InstCombineSimplifyDemanded.cpp | 10 +- lib/Transforms/Utils/CmpInstAnalysis.cpp | 8 +- unittests/ADT/BitVectorTest.cpp | 122 +++++++++++++++++ unittests/CodeGen/ScalableVectorMVTsTest.cpp | 4 +- 22 files changed, 391 insertions(+), 104 deletions(-)