This is an automated email from the git hooks/post-receive script.
unknown user pushed a change to branch master in repository llvm.
from 50e9ffb [AMDGPU] Some code cleaning in SIRegisterInfo.td new b11b352 Rename StringMap::emplace_second to try_emplace. new 1a324fd [DenseMap] Add a C++17-style try_emplace method. new ffecbde [DemandedBits] Reduce number of duplicated DenseMap lookups.
The 3 revisions listed above as "new" are entirely new to this repository and will be described in separate emails. The revisions listed as "adds" were already present in the repository and have only been added to this reference.
Summary of changes: include/llvm/ADT/DenseMap.h | 72 ++++++++++++------------ include/llvm/ADT/StringMap.h | 8 +-- lib/Analysis/DemandedBits.cpp | 9 ++- lib/IR/Metadata.cpp | 2 +- lib/Transforms/Instrumentation/GCOVProfiling.cpp | 2 +- unittests/ADT/DenseMapTest.cpp | 10 ++++ unittests/ADT/StringMapTest.cpp | 2 +- unittests/ProfileData/CoverageMappingTest.cpp | 2 +- 8 files changed, 56 insertions(+), 51 deletions(-)