From: Peter Wang peter.wang@mediatek.com
When setting the ICU bit without using read-modify-write, SQRTCy will restart SQ again and receive an RTC return error code 2 (Failure - SQ not stopped).
Additionally, the error log has been modified so that this type of error can be observed.
Fixes: ab248643d3d6 ("scsi: ufs: core: Add error handling for MCQ mode") Cc: stable@vger.kernel.org Signed-off-by: Peter Wang peter.wang@mediatek.com --- drivers/ufs/core/ufs-mcq.c | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/ufs/core/ufs-mcq.c b/drivers/ufs/core/ufs-mcq.c index 5891cdacd0b3..afd9541f4bd8 100644 --- a/drivers/ufs/core/ufs-mcq.c +++ b/drivers/ufs/core/ufs-mcq.c @@ -570,15 +570,16 @@ int ufshcd_mcq_sq_cleanup(struct ufs_hba *hba, int task_tag) writel(nexus, opr_sqd_base + REG_SQCTI);
/* SQRTCy.ICU = 1 */ - writel(SQ_ICU, opr_sqd_base + REG_SQRTC); + writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU, + opr_sqd_base + REG_SQRTC);
/* Poll SQRTSy.CUS = 1. Return result from SQRTSy.RTC */ reg = opr_sqd_base + REG_SQRTS; err = read_poll_timeout(readl, val, val & SQ_CUS, 20, MCQ_POLL_US, false, reg); - if (err) - dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%ld\n", - __func__, id, task_tag, + if (err || FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg))) + dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%d RTC=%ld\n", + __func__, id, task_tag, err, FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)));
if (ufshcd_mcq_sq_start(hba, hwq))
On Mon, 2024-09-02 at 10:18 +0800, peter.wang@mediatek.com wrote:
From: Peter Wang peter.wang@mediatek.com
When setting the ICU bit without using read-modify-write, SQRTCy will restart SQ again and receive an RTC return error code 2 (Failure - SQ not stopped).
Additionally, the error log has been modified so that this type of error can be observed.
Fixes: ab248643d3d6 ("scsi: ufs: core: Add error handling for MCQ mode") Cc: stable@vger.kernel.org Signed-off-by: Peter Wang peter.wang@mediatek.com
drivers/ufs/core/ufs-mcq.c | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/ufs/core/ufs-mcq.c b/drivers/ufs/core/ufs-mcq.c index 5891cdacd0b3..afd9541f4bd8 100644 --- a/drivers/ufs/core/ufs-mcq.c +++ b/drivers/ufs/core/ufs-mcq.c @@ -570,15 +570,16 @@ int ufshcd_mcq_sq_cleanup(struct ufs_hba *hba, int task_tag) writel(nexus, opr_sqd_base + REG_SQCTI); /* SQRTCy.ICU = 1 */
- writel(SQ_ICU, opr_sqd_base + REG_SQRTC);
- writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU,
opr_sqd_base + REG_SQRTC);
Hi Bao,
Could you help review this patch series? It is a trivial MCQ spec violate bug fixed.
Thanks. Peter
/* Poll SQRTSy.CUS = 1. Return result from SQRTSy.RTC */ reg = opr_sqd_base + REG_SQRTS; err = read_poll_timeout(readl, val, val & SQ_CUS, 20, MCQ_POLL_US, false, reg);
- if (err)
dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d
err=%ld\n",
__func__, id, task_tag,
- if (err || FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)))
dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%d
RTC=%ld\n",
__func__, id, task_tag, err, FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)));
if (ufshcd_mcq_sq_start(hba, hwq))
On 9/1/24 7:18 PM, peter.wang@mediatek.com wrote:
/* SQRTCy.ICU = 1 */
Feel free to leave out the above comment since it duplicates the code below this comment. A comment that explains that "ICU = Initiate Cleanup" probably would be appropriate.
- writel(SQ_ICU, opr_sqd_base + REG_SQRTC);
- writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU,
opr_sqd_base + REG_SQRTC);
Is this perhaps an open-coded version of ufshcd_rmwl()?
/* Poll SQRTSy.CUS = 1. Return result from SQRTSy.RTC */ reg = opr_sqd_base + REG_SQRTS; err = read_poll_timeout(readl, val, val & SQ_CUS, 20, MCQ_POLL_US, false, reg);
- if (err)
dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%ld\n",
__func__, id, task_tag,
- if (err || FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)))
dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%d RTC=%ld\n",
__func__, id, task_tag, err, FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)));
In the above code the expression "FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg))" occurs twice. Please consider storing that expression in a variable such that this expression only occurs once.
Thanks,
Bart.
On Thu, 2024-09-05 at 14:06 -0700, Bart Van Assche wrote:
External email : Please do not click links or open attachments until you have verified the sender or the content. On 9/1/24 7:18 PM, peter.wang@mediatek.com wrote:
/* SQRTCy.ICU = 1 */
Feel free to leave out the above comment since it duplicates the code below this comment. A comment that explains that "ICU = Initiate Cleanup" probably would be appropriate.
Hi Bart,
Will change comment to "/* Initiate Cleanup */"
-writel(SQ_ICU, opr_sqd_base + REG_SQRTC); +writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU, +opr_sqd_base + REG_SQRTC);
Is this perhaps an open-coded version of ufshcd_rmwl()?
ufshcd_rmwl usage includes mmio_base, and it's not suitable for use here.
/* Poll SQRTSy.CUS = 1. Return result from SQRTSy.RTC */ reg = opr_sqd_base + REG_SQRTS; err = read_poll_timeout(readl, val, val & SQ_CUS, 20, MCQ_POLL_US, false, reg); -if (err) -dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%ld\n", -__func__, id, task_tag, +if (err || FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg))) +dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%d RTC=%ld\n", +__func__, id, task_tag, err, FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)));
In the above code the expression "FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg))" occurs twice. Please consider storing that expression in a variable such that this expression only occurs once.
Will use a variable.
Thanks. Peter
Thanks,
Bart.
On 9/1/2024 7:18 PM, peter.wang@mediatek.com wrote:
/* SQRTCy.ICU = 1 */
- writel(SQ_ICU, opr_sqd_base + REG_SQRTC);
- writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU,
opr_sqd_base + REG_SQRTC);
Hi Peter, Instead of readl() here, how about write (SQ_STOP | SQ_ICU) to SQRTC?
Thanks, Bao
On Fri, 2024-09-06 at 13:39 -0700, Bao D. Nguyen wrote:
External email : Please do not click links or open attachments until you have verified the sender or the content. On 9/1/2024 7:18 PM, peter.wang@mediatek.com wrote:
/* SQRTCy.ICU = 1 */ -writel(SQ_ICU, opr_sqd_base + REG_SQRTC); +writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU, +opr_sqd_base + REG_SQRTC);
Hi Peter, Instead of readl() here, how about write (SQ_STOP | SQ_ICU) to SQRTC?
Thanks, Bao
Hi Bao,
My opinion is not to do it this way, because we don't know if the future specification of REG_SQRTC will add extra bits. Once added, such an approach would again become a bug in ufs driver.
Thanks Peter
linux-stable-mirror@lists.linaro.org