From: Shreenidhi Shedi sshedi@vmware.com
Shifting signed 32-bit value by 31 bits is implementation-defined behaviour. Using unsigned is better option for this.
Fixes: 4cca6ea04d31 ("x86/apic: Allow x2apic without IR on VMware platform") Cc: stable@vger.kernel.org Signed-off-by: Shreenidhi Shedi sshedi@vmware.com --- arch/x86/kernel/cpu/vmware.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/x86/kernel/cpu/vmware.c b/arch/x86/kernel/cpu/vmware.c index c04b933f4..02039ec35 100644 --- a/arch/x86/kernel/cpu/vmware.c +++ b/arch/x86/kernel/cpu/vmware.c @@ -476,8 +476,8 @@ static bool __init vmware_legacy_x2apic_available(void) { uint32_t eax, ebx, ecx, edx; VMWARE_CMD(GETVCPU_INFO, eax, ebx, ecx, edx); - return (eax & (1 << VMWARE_CMD_VCPU_RESERVED)) == 0 && - (eax & (1 << VMWARE_CMD_LEGACY_X2APIC)) != 0; + return !(eax & BIT(VMWARE_CMD_VCPU_RESERVED)) && + (eax & BIT(VMWARE_CMD_LEGACY_X2APIC)); }
#ifdef CONFIG_AMD_MEM_ENCRYPT -- 2.36.1
On Fri, May 27, 2022 at 11:27:37PM +0530, Shreenidhi Shedi wrote:
From: Shreenidhi Shedi sshedi@vmware.com
Shifting signed 32-bit value by 31 bits is implementation-defined behaviour. Using unsigned is better option for this.
The kernel builds with -fno-strict-overflow and as such this behaviour is well defined.
Fixes: 4cca6ea04d31 ("x86/apic: Allow x2apic without IR on VMware platform")
Nothing broken, therefore nothing fixed.
On 5/28/22 6:52 AM, Peter Zijlstra wrote:
On Fri, May 27, 2022 at 11:27:37PM +0530, Shreenidhi Shedi wrote:
From: Shreenidhi Shedi sshedi@vmware.com
Shifting signed 32-bit value by 31 bits is implementation-defined behaviour. Using unsigned is better option for this.
The kernel builds with -fno-strict-overflow and as such this behaviour is well defined.
Ah, I see. Thank you, Peter!
Fixes: 4cca6ea04d31 ("x86/apic: Allow x2apic without IR on VMware platform")
Nothing broken, therefore nothing fixed.
Agreed.
I think using the BIT() macro still provides a nice readability improvement. So, Shreenidhi, could you spin a new version of the patch with the same code changes but with a different commit message about using the BIT() macro to simplify the code, and also include a clarification as to why the existing code is correct (which Peter pointed out), please?
Thank you!
Regards, Srivatsa VMware Photon OS
linux-stable-mirror@lists.linaro.org