Not sure nand_cleanup() is the right function to call here but in any case it is not nand_release(). Indeed, even a comment says that calling nand_release() is a bit of a hack as there is no MTD device to unregister. So switch to nand_cleanup() for now and drop this comment.
There is no Fixes tag applying here as the use of nand_release() in this driver predates by far the introduction of nand_cleanup() in commit d44154f969a4 ("mtd: nand: Provide nand_cleanup() function to free NAND related resources") which makes this change possible. However, pointing this commit as the culprit for backporting purposes makes sense even if it did not intruce any bug.
Fixes: d44154f969a4 ("mtd: nand: Provide nand_cleanup() function to free NAND related resources") Signed-off-by: Miquel Raynal miquel.raynal@bootlin.com Cc: stable@vger.kernel.org --- drivers/mtd/nand/raw/diskonchip.c | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/mtd/nand/raw/diskonchip.c b/drivers/mtd/nand/raw/diskonchip.c index 97f0b05b47c1..f8ccee797645 100644 --- a/drivers/mtd/nand/raw/diskonchip.c +++ b/drivers/mtd/nand/raw/diskonchip.c @@ -1482,13 +1482,10 @@ static int __init doc_probe(unsigned long physadr) numchips = doc2001_init(mtd);
if ((ret = nand_scan(nand, numchips)) || (ret = doc->late_init(mtd))) { - /* DBB note: i believe nand_release is necessary here, as + /* DBB note: i believe nand_cleanup is necessary here, as buffers may have been allocated in nand_base. Check with Thomas. FIX ME! */ - /* nand_release will call mtd_device_unregister, but we - haven't yet added it. This is handled without incident by - mtd_device_unregister, as far as I can tell. */ - nand_release(nand); + nand_cleanup(nand); goto fail; }
Hi
[This is an automated email]
This commit has been processed because it contains a "Fixes:" tag fixing commit: d44154f969a4 ("mtd: nand: Provide nand_cleanup() function to free NAND related resources").
The bot has tested the following trees: v5.6.13, v5.4.41, v4.19.123, v4.14.180, v4.9.223.
v5.6.13: Build OK! v5.4.41: Build OK! v4.19.123: Failed to apply! Possible dependencies: 00ad378f304a ("mtd: rawnand: Pass a nand_chip object to nand_scan()") 59ac276f2227 ("mtd: rawnand: Pass a nand_chip object to nand_release()")
v4.14.180: Failed to apply! Possible dependencies: 00ad378f304a ("mtd: rawnand: Pass a nand_chip object to nand_scan()") 02f26ecf8c77 ("mtd: nand: add reworked Marvell NAND controller driver") 1c782b9a8517 ("mtd: nand: mtk: change the compile sequence of mtk_nand.o and mtk_ecc.o") 263c68afb521 ("mtd: nand: pxa3xx_nand: Update Kconfig information") 34832dc44d44 ("mtd: nand: gpmi-nand: Remove wrong Kconfig help text") 577e010c24bc ("mtd: rawnand: atmel: convert driver to nand_scan()") 7928225ffcb3 ("mtd: rawnand: atmel: clarify NAND addition/removal paths") 7cce5d835467 ("MAINTAINERS: mtd/nand: update Microchip nand entry") 7da45139d264 ("mtd: rawnand: better name for the controller structure") 93db446a424c ("mtd: nand: move raw NAND related code to the raw/ subdir") b4525db6f0c6 ("MAINTAINERS: Add entry for Marvell NAND controller driver") d7d9f8ec77fe ("mtd: rawnand: add NVIDIA Tegra NAND Flash controller driver")
v4.9.223: Failed to apply! Possible dependencies: 00ad378f304a ("mtd: rawnand: Pass a nand_chip object to nand_scan()") 24755a55b01f ("Documentation/00-index: update for new core-api folder") 4ad4b21b1b81 ("docs-rst: convert usb docbooks to ReST") 609f212f6a12 ("docs-rst: convert mtdnand book to ReST") 66115335fbb4 ("docs: Fix build failure") 7ddedebb03b7 ("ALSA: doc: ReSTize writing-an-alsa-driver document") 8551914a5e19 ("ALSA: doc: ReSTize alsa-driver-api document") 90f9f118b75c ("docs-rst: convert filesystems book to ReST") 93dc3a112bf8 ("doc: Convert the debugobjects DocBook template to sphinx") c441a4781ff1 ("crypto: doc - remove crypto API DocBook") d6ba7a9c8b5a ("doc: Sphinxify the tracepoint docbook") e7f08ffb1855 ("Documentation/workqueue.txt: convert to ReST markup") f3fc83e55533 ("docs: Fix htmldocs build failure")
NOTE: The patch will not be queued to stable trees until it is upstream.
How should we proceed with this patch?
On Tue, 2020-05-19 at 12:59:45 UTC, Miquel Raynal wrote:
Not sure nand_cleanup() is the right function to call here but in any case it is not nand_release(). Indeed, even a comment says that calling nand_release() is a bit of a hack as there is no MTD device to unregister. So switch to nand_cleanup() for now and drop this comment.
There is no Fixes tag applying here as the use of nand_release() in this driver predates by far the introduction of nand_cleanup() in commit d44154f969a4 ("mtd: nand: Provide nand_cleanup() function to free NAND related resources") which makes this change possible. However, pointing this commit as the culprit for backporting purposes makes sense even if it did not intruce any bug.
Fixes: d44154f969a4 ("mtd: nand: Provide nand_cleanup() function to free NAND related resources") Signed-off-by: Miquel Raynal miquel.raynal@bootlin.com Cc: stable@vger.kernel.org
Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git nand/next.
Miquel
linux-stable-mirror@lists.linaro.org