On 14. 11. 24, 7:26, Jiri Slaby wrote:
--- a/drivers/tty/serial/sh-sci.c +++ b/drivers/tty/serial/sh-sci.c @@ -157,6 +157,7 @@ struct sci_port { bool has_rtscts; bool autorts; + bool first_time_tx;
This is a misnomer. It suggests to be set only during the first TX.
I chose this naming as this was the scenario I discovered it didn't work. Reproducible though these steps:
1/ open the serial device (w/o running any TX/RX) 2/ call tx_empty()
What
about ::did_tx, ::performed_tx, ::transmitted, or alike?
I have nothing against any of these. Can you please let me know if you have a preferred one?
No, you choose, or invent even better one :). Or let AI do it for you.
FWIW both gemini and chatgpt answered by "tx_occurred" to my question. Which I like the most, perhaps.