On (22/12/14 06:57), Ricardo Ribalda wrote:
On (22/12/13 15:35), Ricardo Ribalda wrote: [..]
+++ b/drivers/media/usb/uvc/uvcvideo.h @@ -559,7 +559,7 @@ struct uvc_device { /* Status Interrupt Endpoint */ struct usb_host_endpoint *int_ep; struct urb *int_urb;
u8 *status;
u8 status[UVC_MAX_STATUS_SIZE];
Can we use `struct uvc_control_status status;` instead of open-coding it? Seems that this is what the code wants anyway:
It can also be a `struct uvc_streaming_status`
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/driv...
so we always need the casting :(
Then perhaps we can put both of them into anon union in struct uvc_device as stream_status and control_status?