Hey,
On Wed, Apr 24, 2024 at 07:51:44AM -0700, Sean Christopherson wrote:
On Wed, Apr 24, 2024, Andrew Jones wrote:
On Tue, Apr 23, 2024 at 12:15:47PM -0700, Sean Christopherson wrote: ...
I almost wonder if we should just pick a prefix that's less obviously connected to KVM and/or selftests, but unique and short.
How about kvmsft_ ? It's based on the ksft_ prefix of kselftest.h. Maybe it's too close to ksft though and would be confusing when using both in the same test?
I would prefer something short, and for whatever reason I have a mental block with ksft. I always read it as "k soft", which is completely nonsensical :-)
I despise brevity in tests, so my strong preference is to use some form of 'namespaced' helper. Perhaps others have better memory than I do, but I'm quick to forget the selftests library and find the more verbose / obvious function names helpful for jogging my memory.
I'm not a huge fan of capital letters, but we could also do something like MALLOC()/CALLOC().
Hmm, I'm not usually a fan either, but that could actually work quite well in this case. It would be quite intuitive, easy to visually parse whereas tmalloc() vs malloc() kinda looks like a typo, and would more clearly communicate that they're macros.
Ooo, don't leave me out on the bikeshedding! How about TEST_MALLOC() / TEST_CALLOC(). It is vaguely similar to TEST_ASSERT(), which I'd hope would give the impression that an assertion is lurking below.