On Mon, Mar 24, 2025, Manali Shukla wrote:
Add a refactoring prep patch to move linear_rip out of kvm_pio_request and place it next to complete_userspace_io. There's nothing port I/O specific about linear_rip field, it just so happens to that port I/O is the only case where KVM's ABI is to let userspace stuff state (to emulate RESET) without first completing the I/O instruction.
The shortlog+changelog needs to state what the change is, not what the human that wrote the code is doing. And the changelog needs to state the motivation. Yes, the behavior of linear_rip isn't PIO specific, but the field is obviously specific to PIO, and has been for years, i.e. there's a very good reason why the field is in kvm_pio_request.
KVM: x86: Make kvm_pio_request.linear_rip a common field for user exits
Move and rename kvm_pio_request.linear_rip to kvm_vcpu_arch.cui_linear_rip so that the field can be used by other userspace exit completion flows that need to take action if and only if userspace has not modified RIP.