On 10/16, Christian Brauner wrote:
+static inline bool task_alive(struct pid *pid, enum pid_type type) +{
- return !hlist_empty(&pid->tasks[type]);
+}
So you decided to add a helper ;) OK, but note that its name is very confusing and misleading. Even more than pid_alive() we already have.
What does "alive" actually mean? Say, task_alive(pid, PIDTYPE_SID) == F after fork(). Then it becomes T if this task does setsid().
And why task_ if it accepts pid+pid_type? May be pid_has_task() or something like this...
OK, since I can't suggest a better name I won't really argue. Feel free to add my reviewed-by to this series.
Oleg.