On Thu, Jan 27, 2022 at 4:52 PM Daniel Latypov dlatypov@google.com wrote:
All the operands should be tagged `const`. We're only assigning them to variables so that we can compare them (e.g. check if left == right, etc.) and avoid evaluating expressions multiple times.
There's no need for them to be mutable.
Agreed.
Also rename the helper variable `loc` to `__loc` like we do with `__assertion` and `__strs` to avoid potential name collisions with user code.
Probably not necessary since we create a new code block (we are inside of an if-statement, do-while-loop, etc), but I don't really care either way.
Signed-off-by: Daniel Latypov dlatypov@google.com
Reviewed-by: Brendan Higgins brendanhiggins@google.com