On Thu, Apr 24, 2025 at 11:58 PM Maxime Ripard mripard@kernel.org wrote:
On Thu, Apr 24, 2025 at 05:13:47PM -0700, John Stultz wrote:
On Thu, Apr 24, 2025 at 1:34 AM Maxime Ripard mripard@kernel.org wrote:
I appreciate this is kind of bikeshed-color territory, but I think "cma" would be a better option here. There's nothing "default" about it.
I disagree. It very much is "default" as it's returning the dma_contiguous_default_area.
My main concern here is that it's "default" as opposed to what, exactly? We have a single CMA allocator. We could have multiple buffer attributes, but then "cached_cma" would make more sense to me if we expect to have uncached CMA allocations at some point.
Well, there may be one CMA allocator, but there can be multiple CMA regions.
So in the kernel, cma_alloc() always takes the cma area as an argument. And dma_alloc_contiguous() lets you do allocations against a device, which may reference a specific cma area. Or if the device doesn't specify a region it will utilize the default region.
There can be multiple CMA areas, and out of tree, vendors do reserve separate areas for specific purposes, exposing multiple CMA dmabuf heaps.
By "CMA areas", I guess you mean carved-out memory regions? If so, how is it relevant to userspace if we use CMA or any other implementation to expose a carved-out region, and thus that we carry that implemenattion detail in the name?
So, no, I don't mean carve-out regions. It's more about dealing with competition between multiple CMA users. In some cases, where there are known fixed buffer sizes, say camera buffers, it's much easier to reserve a separate specific sized region to allocate from so that you know it will always succeed and you don't need to waste much on safety margins. Having this added as a separate CMA region makes it a lot easier to account or reason about, and the kernel can still make (limited) use of the CMA space when it's idle. Then you don't have to worry about some other device having a short term cma allocation that pushes back the alignment for your large allocation, possibly impacting some other devices larger allocations.
And unlike with just using a carveout, you don't end up just wasting all that space when it is unused.
So userland may want to allocate contiguous memory, but it may also be relevant to userland to be able to allocate contiguous memory from a purpose specific pool.
And while not used in Android, you could imagine having separate purpose reserved cma heaps with different permissions on the heap devnodes, allowing less trusted applications to allocate cma from a small pool without having the potential to DoS the system.
There have been patches to expose multiple CMA heaps, but with no upstream drivers using those purpose specific regions, we haven't taken them yet. I do hope as the drivers that utilize these purpose focused heaps go upstream, we can add that logic, so I think being specific that this is default CMA is a good idea.
If heaps names are supposed to carry the region it exposes, then it should be default_cma_region/area. If heap names are supposed to expose the allocator (but I don't think it's a good idea), it should be cma. If they are meant to carry all that plus some policy, cached_default_cma_region should be used.
Either way, default_cma seems to me either too specific or not specific enough. And we should really document what the policy for those heaps are supposed to be.
I don't see it as such a problem. It is clear it is cma, it also is clear conceptually that it is the "default" region that the kernel uses when devices aren't specific. But I wouldn't object to cma_default_region/area as a name either, but I don't see it as particularly improved over cma_default.
To your larger point about policy, I do get the tension that you want to be able to programmatically derive or evaluate heap names, so that applications can consistently derive a pathname to get what they want. But I also think that there is so much variety in both the devices and uses that there is no way that all use cases and all devices can be satisfied with such a static or even programmatic mapping. From my perspective, there just is going to have to be some device specific glue logic that maps use->heap name. Same reason we have fstab and the passwd file. That said, I think advocating for naming conventions is definitely useful, but I'm wary of trying to enforce too specific a schema on the names as the incompleteness theorem will bite us.
thanks -john